npm.devtool.tech
👏 You can access remark-lint package with using remarkLint variable in browser devtools!
remark plugin to lint Markdown code style

code/package/bundle size

0B
publish
0B
install
0B
bundle minified
0B
bundle gzipped

remark-lint

Build Coverage Downloads Size Sponsors Backers Chat

remark plugin to lint Markdown code style.

Read more about remark-lint on the monorepo readme.

This package doesn’t do much other than suppressing messages through comments.

If you’re using presets, they already include remark-lint itself. If you’re using just plugins, you have to include remark-lint explicitly.

Install

This package is ESM only: Node 12+ is needed to use it and it must be imported instead of required.

npm:

npm install remark-lint

Use

You probably want to use it on the CLI through a config file:

 …
 "remarkConfig": {
   "plugins": [
     …
+    "lint",
     …
   ]
 }
 …

Or use it on the CLI directly

remark -u lint readme.md

Or use this on the API:

 import {remark} from 'remark'
 import {reporter} from 'vfile-reporter'
 import remarkLint from 'remarkLint'

 remark()
+  .use(remarkLint)
   .process('_Emphasis_ and **importance**')
   .then((file) => {
     console.error(reporter(file))
   })

Contribute

See contributing.md in remarkjs/.github for ways to get started. See support.md for ways to get help.

This project has a code of conduct. By interacting with this repository, organization, or community you agree to abide by its terms.

License

MIT © Titus Wormer

🔎Explore Package🔎CDN Script

Score

Popularity28/100
Quality92/100
Maintenance100/100